Author Topic: 22RE loads down at idle - normal?  (Read 3547 times)

Offline chicomecha

  • Dep. Web Wheeler
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 386
22RE loads down at idle - normal?
« on: March 10, 2007, 09:01:34 AM »
In my daughters '85 Toy ('91 engine, '87 EFI) it sounds beautiful at around 900 to 1000 RPM (by ear) and higher, but then as you drop the RPM a bit, it seems like you can feel a load come on the engine, and it drops the RPM right down to idle, and it sounds much rougher.  It is almost impossible to get the engine to run ay RPM's between there.  Any ideas what this might be?  Vacuum related?  Exhaust system related?
"If you're lucky enough to be in the mountains, you're lucky enough."
N6RCJ

Offline toyoder

  • Sr. Member
  • ****
  • Posts: 60
Re: 22RE loads down at idle - normal?
« Reply #1 on: March 10, 2007, 01:27:43 PM »
sounds like a tps or egr problem

Offline chicomecha

  • Dep. Web Wheeler
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 386
Re: 22RE loads down at idle - normal?
« Reply #2 on: March 14, 2007, 05:40:12 PM »
Not sure what TPS is, or how to check the EGR, but I had a friend of a friend (who just happens to own another '85 Toyota, 6" lift, ARB's etc, original owner) that also happened to work as a Toyota tech for 17 years, come look and listen.

He quickly pointed out the rather bad exhaust leak at the junction of the header and manifold.  He put a rag over the exhaust pipe, and the engine didn't miss a beat.  OOPS.  He also pointed out a vacuum leak on a sensor, but verified the rest was pretty tidy.  So we'll fix those things, and then see about it again.  Thanks for your help, so far...

His rig, and he's ready for Pipejam
"If you're lucky enough to be in the mountains, you're lucky enough."
N6RCJ